Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22

Thread: My Passion/My Style/My Beauty <---> PALIO 1.9D ELX <---> Service-Maintenance-Cost

  1. #21
    Member
    Join Date
    Dec 2013
    Location
    Erode (Tamil Nadu) / Bangalore
    Posts
    88
    Thanks
    21
    Thanked 35 Times in 20 Posts

    Re: My Passion/My Style/My Beauty <---> PALIO 1.9D ELX <---> Service-Maintenance-Cost

    Guys... need your help..

    Car was working fine until last week.. I replaced Diesel filter and filter valve with OE parts. Well after several cranks, car started and worked fine. It was running smooth. Later we found a slight diesel leakage in the water sensor under the diesel filter. so we removed and fitted new o-ring but while tightening water sensor broken and stuck inside, so we had to remove the filter again and removed the broken plastic. Bought new water sensor and replaced.

    From then, car will start and immediately switch off after few seconds. Sometimes, if we press the accelerator pedal car will run maximum rpm and switches after sometime.

    Not sure why suddenly this problem started. May be due to air lock? then we removed diesel overflow tube near manifold, diesel seems to be coming very less while running (somehow we managed to run the car for a minute by pressing more acceleration). So we understand engine is not getting enough diesel.

    I read this forum, where Vasanth sir mentioned when we switch on the key, electric fuel pump should work for few seconds and we should get a sound near back seat. But in my case i didn't heard any sound, so we checked fuel pump relay but it was fine. Now we removed the fuel pump in the tank.

    And i am confused only sensor for fuel level indicator was there and there was no motor in the fuel pump located in tank.. If there is no motor how comes diesel is sucked from tank? can anybody throw some light on this?

  2. #22
    Member
    Join Date
    Dec 2013
    Location
    Erode (Tamil Nadu) / Bangalore
    Posts
    88
    Thanks
    21
    Thanked 35 Times in 20 Posts

    Re: My Passion/My Style/My Beauty <---> PALIO 1.9D ELX <---> Service-Maintenance-Cost

    Finally solved the starting problem in my Palio 1.9 !!! the culprit is the ECU/Motherboard. Sourced the second hand ECU and car started in first crank!!

    For past few years, car would always start in 2nd crank/3rd crank even the battery was new/fully charged. Now i suspect it might be because of faulty ECU, now it has completely blown off.

    Finding a real problem in Palio 1.9 is always challenging and frustrating!!

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •